Garmaine Staff asked 2 years ago

A friend of mine has a very strange condition with the electrical system in his room. Connected to mains, there is mainly an audio system, a computer and, most importantly electrical shutters. They are on all windows in the house.

Now, here is the problem: When the shutters stop moving, there is an audible click in the speakers. This is not a fault with the speakers, as they are relatively new and not the only thing affected. But that's not the best of it: Sometimes, when the click is very loud, the PC's drivers crash (LED illumination goes dark, audio driver crashes, …). I could not reproduce this myself, but I have seen a video of it happening.

They had an electrician over to install some new outlets in the room and asked them about it, but the electrician did not know a solution to the problem either. I am a electronics hobbyist, and my friend asked me to look at the system. What I measured was as expected, that there is a voltage spike on the power line when the shutters stop.

This affects both L/N and the ground. I don't have pro equipment, and only an ebay oscilloscope and multimeter but even then there is a measurable voltage spike both on the ground conductor relative to a metal doorframe or air, and also between the mains wires when the shutters stop moving.

For testing, I isolated the ground prong for the speakers, and the click got much much weaker but still audible (I reversed this modification afterwards of course), so the problem is mainly with the ground line.

I assume that this is due to the coils in the motor of the electric shutter firing current back into the powerlines. Unfortunately, I don't have access to this shutter's wirings as it is mounted inside the walls. But I don't think that the unit is faulty, because the same occurs (although much weaker) when you move any other electric shutter in the house.

I have measured the mains voltage (between 230-235V at stable 50 Hz), the voltage between PE and N (~0.1-1V), and tried measuring if there was voltage on the ground line with the NCV on my multimeter, but everything seemed OK. Also, the house is pretty new.

Can this still be a fault of the power system, or is this just bad design of the shutters?

Also, what can be done to prevent the computer from being affected so strongly by this? I thought about an 1:1 isolating transformer, but that doesn't isolate the ground line IIRC.

Thank you in advance